Achilles Platforms - Unable to access

Incident Report for Achilles Global Risk Management

Resolved

This incident has been resolved.
Posted Jul 01, 2026 - 08:02 BST

Monitoring

Services have been restored and we are monitoring the situation closely with Microsoft following the resolution of the issue
Posted Jul 01, 2026 - 04:29 BST

Investigating

We are aware of an issue being reported by customers unable to access to Achilles services.

We are working with our third party providers to investigate the issue urgently.
Posted Jul 01, 2026 - 03:39 BST
This incident affected: MyAchilles Networks (Supply-Line, UVDB, Middle East & Africa Network, Global Energy, Link-up, BuildingConfidence, Services and Industries, TransQ, Achilles Network, Technology, Utilities Nordics and Central Europe, Regic, Repro, StartBANK, BDPC - PetroPeru) and Controllar, GoSupply, www.achilles.com.