MyAchilles - Scoring and Compliance recalculations

Incident Report for Achilles

Resolved

Socring and compliance transactions are now processing as normal
Posted Jan 30, 2025 - 20:55 GMT

Investigating

We are currently investigating reports of delays in scoring and compliance recalculations.
Posted Jan 30, 2025 - 11:02 GMT
This incident affected: MyAchilles Networks (Supply-Line, UVDB, Middle East & Africa Network, Global Energy, Link-up, BuildingConfidence, Services and Industries, TransQ, Achilles Network, Technology, Utilities Nordics and Central Europe, Regic, Repro, StartBANK, PEMEX, BDPC - PetroPeru) and Analytics and Audit Search, Data Exchange Services.