MyAchilles - Repro registration process
Incident Report for Achilles
Resolved
This incident has been resolved.
Posted Aug 10, 2022 - 13:00 BST
Update
We are continuing to monitor for any further issues.
Posted Jul 13, 2022 - 17:28 BST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 13, 2022 - 17:24 BST
Identified
A root cause has been identified and a fix is being analysed
Posted Jul 13, 2022 - 16:10 BST
Investigating
We are investigating an issue were some suppliers are unable to complete the registration process for Repro.
Posted Jul 12, 2022 - 17:00 BST
This incident affected: MyAchilles - https://my.achilles.com (Repro).