Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 31, 2025 - 14:00 GMT
Scheduled
A release has been scheduled to the MyAchilles platform.
Major enhancements to the supplier questionnaire are being released today to improve usability and functionality.
Interface redesign: - More manageable module-by-module pages rather than lengthy whole-section pages - New question/response display makes responses easier to select and shows help text immediately - New module navigation pages with clear statuses. - Mandatory questions indicated clearly with asterisks - Suppliers can jump about freely in the edit view of the questionnaire when completing content - Questions triggered by responses are shown more clearly with indentation - Navigation progress bar on question module pages Note that buyers will notice some of these changes as they will see a stripped down read-only view of the interface.
Automated validation: - Sophisticated automated checks have been developed to ensure that responses 'make sense' in the context of other content in the questionnaire. - Suppliers can trigger these checks before submitting their questionnaire to Achilles. This means that issues can be corrected up front and the publication process is streamlined. - New 'Run checks' buttons will appear for modules when content has been changed. These must be run before submission. If after three failed attempts the issue cannot be resolved, the system will allow submission and manual validation. While the checks are running suppliers can continue to navigate around the questionnaire.
During this release the system will continue to be accessible for users.
Posted Oct 31, 2025 - 10:44 GMT
This scheduled maintenance affected: MyAchilles Networks (Supply-Line, UVDB, Middle East & Africa Network, Global Energy, Link-up, BuildingConfidence, Services and Industries, TransQ, Achilles Network, Technology, Utilities Nordics and Central Europe, Regic, Repro, StartBANK, PEMEX, BDPC - PetroPeru).