MyAchilles - Data Exchange slowness
Incident Report for Achilles
Resolved
This incident has been resolved.
Posted Apr 08, 2024 - 00:19 BST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 07, 2024 - 18:00 BST
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 07, 2024 - 14:00 BST
Investigating
Dear Customer,

We are currently investigating an issue where slowness has been observed in the data exchange when customers are attempting to export data for multiple suppliers in batches.

We are working to investigate and resolve this as quickly as possible. Please accept our apologies for any inconvenience caused.

Kind regards
Achilles
Posted Apr 07, 2024 - 11:26 BST
This incident affected: Data Exchange Services.